Which are the requirements for installing SMF?

Which are the requirements for installing SMF?

Add Comment
1 Answer(s)
Best answer

The following are required on any server intending to run SMF 2.x.x

A webserver that supports PHP, such as Apache

  • PHP 4.1.0 or higher
  • The engine directive must be set to on.
  • The magic_quotes_sybase directive must be set to off.
  • The session.save_path directive must be set to a valid directory or empty.
  • The file_uploads directive must be set to on.
  • The upload_tmp_dir directive must be set to a valid directory or empty.

One of the following databases must be installed:

  • MySQL 4.0.18 or higher (at least 4.1.0 would be better) and PHP MySQL client API 4.0.18 or higher.
  • PostgreSQL 8.0 or higher (standard_conforming_strings must be set to off, starting from PostgreSQL 9.1 default is on)
  • SQLite SQLite 2.x (SMF is not compatible with SQLite 3.x)
Christian Smith Answered on September 25, 2015.
Add Comment

Your Answer

By posting your answer, you agree to the privacy policy and terms of service.